Author Topic: msCam Frame retrieve error  (Read 2688 times)

hansu47p

  • Newbie
  • *
  • Karma: +0/-0
    • View Profile
msCam Frame retrieve error
« on: April 17, 2018, 09:26:23 AM »
Hi,

My name is Su and I need your help.
I have been using the miniscope with the version3 DAQ with Dell computer (Windows 10) which had been working fine, but suddenly stopped working as the video stream is lost (the red screen of Doom appears with the message of 'frame retrieve error).
All 3 LED lights come on the DAQ PCB and the red light on CMOS sensor and the blue LED are also on when I plug the scope in. I am using the proper USB 3.0 cable (1m long) and when the miniscope is plugged in I still see the miniscope driver on Device manager. I have tried 3 different DAQ, 2 USB cables and 2 different miniscopes but it still shows the msCam frame retrieve error.
Is there any suggestion on what would have been a problem?
Thank you!
« Last Edit: April 17, 2018, 10:06:55 AM by hansu47p »

Daniel Aharoni

  • Administrator
  • Full Member
  • *****
  • Karma: +15/-0
    • View Profile
Re: msCam Frame retrieve error
« Reply #1 on: May 18, 2018, 04:36:08 PM »
Hi hansu,
Can you try connecting to the Miniscope with a different Windows 10 computer. If the issue you are having persists across multiple Miniscope system then it is likely the issue has something to do with your computer.

The other source of this issue could be if you had a short across the SMA2Coax PCB and then powered on the DAQ PCB. This can cause a power surge across an inductor on the DAQ PCB causing all 3 green LEDs to stay on but the actual data signal being received by the DAQ PCB to be corrupted. If this happened it is pretty easy to fix it by replacing the L13 inductor on the DAQ PCB.

Let me know once you have tried a different computer and if you think there was a chance you had a short on the SMA2Coax PCB at some point in the past.