Miniscope Board

General Category => DAQ Software/Firmware => Topic started by: jasperp on November 28, 2016, 11:29:36 AM

Title: problem changing excitation LED power
Post by: jasperp on November 28, 2016, 11:29:36 AM
Dear all,

I am having an issue changing the intensity of the excitation LED using the GUI:
- All 3 LEDs on the DAQ board are on
- on the image sensor PCB there is a red LED on
- the blue excitation LED is illuminated when I plug in the USB cable
- I am able to connect to the scope and the sensor appears to be working, but when I change the excitation LED power nothing happens, although the message window in the GUI says: 'LED power updated: 0' up until 'LED power updated: 100'

I was wondering if anyone has encountered this issue before? Any suggestions what to check/try are greatly appreciated!

best, Jasper
Title: Re: problem changing excitation LED power
Post by: Daniel Aharoni on November 28, 2016, 11:43:28 PM
Hi Jasper,
Most likely you are using version 3.2 of the CMOS imaging sensor PCB and forgot to short with solder the 2 half circles on the bottom of the PCB. Check out the soldering the solder-jumper section of our tutorial here, Please respond to this post with an update. Thanks!
Title: Re: problem changing excitation LED power
Post by: jaspoo on December 01, 2016, 01:25:12 PM
Hi Daniel,

Thanks for your suggestion: I am indeed using version 3.2, but I did already solder the solder-jumper on the bottom of the PCB (just double checked with two different CMOS PCBs; they both have the same issue but both have the jumper connected).

Is there perhaps a quick way to probe whether the solder-jumper is working as it should on the other side of the board?
Or is there any other possible cause? Is the LED supposed to turn on the moment you connect the DAQ PCB to the USB?


Title: Re: problem changing excitation LED power
Post by: Daniel Aharoni on December 01, 2016, 04:57:16 PM
Hi Jasper,
Yes the excitation LED should turn on very weakly right when the CMOS PCB is powered up. When you change the exposure or gain in the DAQ software do you see the correct change in the video streaming from the imaging sensor?

If the solder-jumper has been shorted then the next likely causes would be:
- The LED is improperly soldered to the LED PCB
- The LED is improperly wired up to the CMOS PCB
- The LED has been damaged when removing the silicone dome. This is the most likely option.

If you touched the light emitting part of the LED while removing the silicone protective dome then the LED could be damaged and not respond to increases in current. They soldering a new LED and LED PCB without removing the silicone dome. Attach the new LED to the CMOS PCB and see if you can get the light intensity to change.

If the above doesn't solve the problem then I would suggest using a multimeter in series with the LED (make sure this LED hasn't been damaged) and measure the current flowing. You should see an increase in current as you increase excitation intensity through the DAQ software. 1% in the software is around 1mA, 10% in the software is around 10mA.

Title: Re: problem changing excitation LED power
Post by: jaspoo on December 01, 2016, 07:21:26 PM
Hi Daniel, many thanks for your comments. To answer your questions:
- changing exposure or gain does indeed have the expected effect on the video stream
- the LED is not damaged (I'm testing this with an LED that still has the silicone and I am able to increase or dim LED intensity using a separate power supply with variable resistor)
- I also think it is correctly wired to the CMOS otherwise I think it would not light up at all?
- When I connect a multimeter to the CMOS output without any LED, the excitation LED slider in the GUI increases the current from 0.04mA at 0 to 20mA at 20 and 40mA at 40%. However, when I directly connect the cathode and anode of the LED, the current is about .1 mA and does not change when I change the slider... When I connect the CMOS output to the LED board with the soldered LED, the current is also ~0.1 mA and I am not able to change it by moving the GUI slider. Should I expect any difference between using the LED directly vs the LED on the LED board? If you have any other suggestion what is going on that is very much appreciated! Best, Jasper

Title: Re: problem changing excitation LED power
Post by: Daniel Aharoni on December 01, 2016, 08:40:40 PM
This is very interesting. So it appears that the computer isn't having any issue communicating to the CMOS PCB and the LED driver circuitry (which consists of an I2C addressable DAC connected to a constant current source) is responding correctly when there is only a multimeter attached to the + and - pads on the CMOS PCB. But when you hook up and LED (directly or on the LED board doesn't matter) the LED driver circuitry output sits at 0.1mA.

The first thing that comes to mind is a multimeter in current mode is a much smaller load than an LED. For example, passing 20mA through a multimeter will result in a very tiny voltage drop across the input/output of the current source where as 20mA through an LED will end up producing a ~3V voltage drop. Maybe the LED driver current source is having trouble sourcing enough power when driving the LED.

- What size and hold long of a coax cable are you using? Can you measure the voltage difference across the inner conductor and outer shield of the coax cable right where it connects to the CMOS PCB? In other words, power everything up and measure the voltage across the 2 solder connections where the coax cable connects to the CMOS PCB.
- Can you take a picture of the top and bottom of the CMOS PCB and share them?

Title: Re: problem changing excitation LED power
Post by: jaspoo on December 02, 2016, 03:29:23 PM
I'm using the thin Mouser coaxial cable (42AWG, 50 OHM, 538-50MCX-37), cable length is about 150cm/5ft. The voltage measured at the solder joint of the CMOS PCB with the coaxial cable is 2.3V and the voltage at the solder join of the LED PCB with the coaxial cable is also 2.3V (when I measure the voltage at the SMA connecting the DAQ PCB to the coaxial cable it is 4.7V). I have attached a picture of the top and bottom. I will next try to find a  different type of thin coaxial cable from maybe digikey (Cooner wire is harder to get hold of here). If you have any other suggestions what could be the problem that would be great, thanks!

Here are the pics of the CMOS:
Title: Re: problem changing excitation LED power
Post by: Daniel Aharoni on December 02, 2016, 06:51:59 PM
Thanks Jasper. I think I now know the source of the issue. The CMOS PCB needs an input voltage of at least ~4V to run properly. At 2.3V I am surprised even the image sensor itself is functional. Your thin coax cable has too large of a voltage drop due to high resistivity, dropping the ~5V USB power to 2.3V by the time it reaches the CMOS PCB. At 2.3V, the LED driver circuitry can't push more than ~0.1mA through the LED.

Here are a few solutions that each should fix the problem on their own:
- Cut your coax cable down to just a foot or two. This won't be practical during experiments but it will raise the voltage getting to the PCB and you should be able to control the LED intensity.
- Use the DC power jack to supply power to the CMOS PCB. The jumper J9 allows your to switch between USB power and power from the DC power jack. You can hook up a 9V or 12V power supply (don't go above 12V) to the jack which should fix your issue. There will still be a significant voltage drop across your coax cable but the voltage reaching the CMOS PCB will be well over 5V. If you do use the DC jack make sure you get the polarity correct. The inner pin of the jack should be positive voltage, the outer should be ground (
- Use a larger coax. We like the Cooner Wire coax cable because they are very strong but still flexible. We generally build 10 foot cables and have no issue with the voltage drop across them.
Title: Re: problem changing excitation LED power
Post by: jaspoo on December 03, 2016, 09:31:22 PM
Hi Daniel, thanks again, it seems indeed to be an issue with too little voltage being sent from the CMOS to the LED: it is still not fully clear what is going on, I tried the following:
1) use long mouser cable: measure 3.4V at sig/gnd on CMOS PCB, 2.3V on LED output CMOS, 3rd top LED on the DAQ PCB is on > cannot control LED intensity
2) short RG58 50Ohm coaxial cable 4.8V at sig/gnd on CMOS PCB, 2.6V to LED, 3rd LED is not on > cannot connect to the scope

Unfortunately, I now started to get again "msCam frame retrieve error!" with setup 1 (using 2 different DAQ boards and 2 different CMOS PCBs that previously worked), even though all three LEDs are on, and the same voltages are measured (3.4V at sig/gnd on CMOS PCB, 2.3VLED on LED output CMOS). I will try to find another USB3.0 port (so far this was the only USB3.0 port on which I got the boards to work) but if you have any other ideas what to check let me know.
Title: Re: problem changing excitation LED power
Post by: nh88 on December 05, 2016, 02:32:18 PM
I had a similar issue with the mouser cable and needed to use an external power supply to get the LED to respond properly. More than a few feet of the mouser cable causes problems. The other type of coax cable is much stronger and better and you can get away with longer lengths without these problems.
Not sure about the frame retrieve error but I had to be very careful with the soldering of the coax cable to the camera to ensure that I did not cause shorts close to where the coax cable is fixed to the sensor board.